How to use SlideApplicationFrame correctly

Oct 1, 2014 at 8:11 AM

I create this thread because I have some troubles with SlideApplicationFrame. I currently develop an universal Windows Store app for Windows 8.1 and Windows Phone 8.1 with Visual Studio 2013 (two apps => one solution).

I read on this site it doesn't work when you add it by Nuget Packages Manager so I downloaded the code samples and added SlideView.Library.WP81 project to my solution.

Every time I build my solution, I have error "Could not find Windows Runtime type 'Windows.UI.Xaml.TickBar' " in my App.xaml file of the Windows Phone project. I have one App.xaml file for each plat-form, it is not shared. The error concern the content of <Application.Resources>. I coded juste like the WP8.1 sample :
        <library:SlideApplicationFrame Header="ElleHoroscope" Background="White" x:Key="RootFrame">
I've changed my App.xaml.cs like the sample code. I replace Frame by SlideApplicationFrame class. I've read all the thread about SlideApplicationFrame but I'm still lost.

Someone can help me?

In advance, thank you very much

Nov 4, 2014 at 4:55 PM
Same problem for me... so i tried to run your Sample "SlideView.Sample.WP81", but it doesn't build for the same error:
Could not find Windows Runtime type 'Windows.UI.Xaml.TickBar'.
Thank you for your time.
Nov 5, 2014 at 12:56 PM
Edited Nov 5, 2014 at 4:55 PM
Use the package manager console to install the package.

In Visual Studio 2013, in the search box on the top right hand corner, type in "Package Manager Console"(without " ") and press enter, click on the Package Manger Console.

Then in the package manager console which would have initialized in the bottom, paste this

Install-Package SlideView and press enter.

SlideView will get installed. Make sure you have the latest version of Package Manager installed on your machine.

And if you have done this and it still isn't working, try adding this line to the declarations
Hope this helps!
Mar 4, 2015 at 6:18 PM
Hi @SiddAjmera,
The solution hasn't helped me.
I am developing an universal app & tried to use this library for the phone-app, but was getting this error.

So, I created a new test-application & followed the steps you've mentioned - but unfortunately, there's no luck :(

Can anyone please solve this issue ASAP?
Mar 18, 2015 at 4:31 PM

Can you please copy the content from your App.xaml (RootVisual) and App.xaml.cs ?